vue安装配置&常用命令

默认分类 / 148人浏览 / 0人评论

vue安装及配置

node.js要求版本在8.9以上   官网:https://nodejs.org/zh-cn/

下载完可检查:node -v

淘宝NPM镜像源:npm install -g cnpm --registry=https://registry.npm.taobao.org

安装vue-cli(全局安装vue-cli):(c)npm install -g @vue/cli

检查环境:vue -V

创建vue项目:vue create demo(创建名字为‘demo’的文件夹)

// 根据项目需要来选择配置,空格键是选中与取消,A键是全选
// 检查项目所需的功能:(按<space>选择,<a>切换所有,<i>反转选择)
>( ) TypeScript                                 // 支持使用 TypeScript 书写源码
 ( ) Progressive Web App (PWA) Support          // PWA 支持
 ( ) Router                                     // 支持 vue-router
 ( ) Vuex                                       // 支持 vuex
 ( ) CSS Pre-processors                         // 支持 CSS 预处理器。
 ( ) Linter / Formatter                         // 支持代码风格检查和格式化。
 ( ) Unit Testing                               // 支持单元测试。
 ( ) E2E Testing  
Save this as a preset for future projects? (Y/n) // 是否记录一下以便下次继续使用这套配置
// 选保存之后,会让你写一个配置的名字:
Save preset as:  name // 然后你下次进入配置可以直接使用你这次的配置了


安装:npm install

运行:npm run dev

删除:npm uninstall 包名

卸载老版本vuecli:npm uninstall vue-cli -g

安装新版本vuecli:npm install -g @vue/cli

安装5个样式相关:npm i vue-style-loader less-loader css-loader vue-loader less

安装less 和less-loader:npm install less less-loader --save

安装vant:npm i vant -S

安装js-base64:npm install --save js-base64

安装axios:npm install axios



感谢博主,喝杯咖啡~

0 条评论

还没有人发表评论

发表评论 取消回复

记住我的信息,方便下次评论
有人回复时邮件通知我